Symptom
An accrual rule has been created that uses the rule function 'Calculate Average Value For Numeric Job Info Field()' and the accrual amount has posted the incorrect value for some user(s).
Environment
Product version: SAP SuccessFactors HCM Core 2405
Employee Central - Time Off > Accruals
Reproducing the Issue
- You have set the field value to X for the entire year (e.g. X=10)
- This has not changed, except the user was absent on a LOA for 1 month
- The average value found in the rule trace gives an unexpected figure, for example, 10.87
- You are wondering why the value is 10.87 instead of 10
Cause
The Consider Eligibility field in the accrual rule configuration is set to 'Yes'.
Meaning the system will count the average only for the period in which the user is eligible, so in this scenario, the user was not eligible for 1 month. Therefore the average will move from 10 to 10.87, which is the average of the eligible period.
Resolution
When using the Calculate Average Value For Numeric Job Info Field() field in the accrual rule, if the Consider Eligibility is set to Yes in the rule, and the user with the incorrect accrual amount is on Leave of Absence (LOA) during the accrual/accruable period e.g. 2024, this will skew the average value, as the rule function does not consider the period the user is on LOA for the calculation of the average value.
Any accruals already posted incorrectly should be adjusted manually using the Add Posting > Manual Adjustment feature in the affected employee's workbench.
Keywords
accrual, Incorrect Accrual Posting, Calculate Average Value For Numeric Job Info Field(), Accrual Rule Configuration, LOA record , KBA , LOD-SF-EC-TIM-RUL , TAT Rules, Validation & Take rules , Problem