Symptom
When creating Service Purchase Orders via the migration cockpit the service performance start and end date are maintained.
The Performance Period End Date is a date in the future. However after successfully migrating the purchase orders, it is noted that the start date and the end date have been set to today's date. The data in the template is over looked.
Environment
SAP S/4Hana Public Cloud Edition
Reproducing the Issue
1) Create a Project in the Migration Project
2) Assign Migration Object MM - Purchase order (only open PO)
3) Download the template for creating purchase Orders
4) Maintained template with the PO master data
5) Execute the validations, mapping steps and simulation
6) Execute the migration
7) Note the Performance Dates in the PO created are not those defined in the template
Cause
Missing data in the item data of the template.
If the 'Product type group' is missing in the item data the system defaults the system date into the fields.
Resolution
When migrating a service PO item make sure you maintain the 'Product type group' = '2' along with the performance dates.
This applies if you maintain a service Material ID or only a service description. The product type group '2' is needed for the
system to set the performance dates correctly.
See Also
Check the description of the product type group field in the excel template
Keywords
DMCC_MIG_PUR_PO_CREATE, MAP2E_ITEM_TO_BAPIITEM, BAPI_PO_CREATE1, mepoitem-startdate, mepoitem-enddate, LMEPOF2W, FORM MEPO_SCHEDULES_PROCESS , KBA , MM-PUR-PO-2CL , Purchase Orders (Public Cloud) , How To