Symptom
- Manager's phone number is not visible on the welcome message card or useful contact
- The manager's contact information is provided in the system but not displayed
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as a candidate
- Click on the Welcome Aboard! card
- Observe that the manager's contact information is not visible
Cause
- The user does not have sufficient RBP Permissions to read the Manager's Phone Number.
- Onboarding BPE Service User does not have sufficient RBP Permissions to read the Manager's Phone Number.
Resolution
- Navigate to Manage Permission Role > Any RBP Role/OnboardingBPEAdmin the affected user is a part of
- Click on Permissions > Employee Data
- Under "Employee Profile", enable "Business Phone Number"
- Click on Save
- Ensure the Manager has valid Contact Information in their respective Employee Profile.
- The user viewing the welcome message card should have permission to see the manager details via WorkProfile API.
Keywords
onboarding, obx, permission, manager phone number, missing, phone number welcome card , KBA , LOD-SF-OBX-NHA , New Hire Activities (activities, tasks, buddy, equipment) , Problem
Product
SAP SuccessFactors Onboarding all versions