Symptom
An error occurs when attempting to publish data to Employee Central.
Environment
- SAP SucessFactors HCM Suite
- SAP SucessFactors Compensation
- SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to the Admin Center and go to Compensation Home.
- Select the desired Compensation template.
- Complete the Compensation Cycle.
- Publish Data.
- Publish Selected Employees in Employee Central or Publish Selected Worksheets in Employee Central
- Use the search tool to type "Monitor Job."
- Select the job and click on "Download Status."
You may encounter the error message: "It is not supported to change effective date/event reason/publish order on 2nd+ publish."
Cause
The issue typically occurs when the same template has been used multiple times. If a worksheet has been used to publish from Compensation to Employee Central multiple times and the compensation record is then deleted, an error occurs when attempting to republish.
Resolution
To resolve this issue you can:
- Clear all published data for the affected users before relaunching the form.
- If the issue persists, clone the template and create a new worksheet for publishing.
See Also
Refer to the following for additional information and guidance:
Customer Services & Support Knowledge - Compensation to EC publish error: publish date error | HCSM
Keywords
publishing ec data, compensation, ec, publish, error, job failing, effective date, publish order, second publish, compensation worksheets, error message , KBA , LOD-SF-CMP-EC , EC data, EC mappings, configuration & settings , LOD-SF-CMP , Compensation Management , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , Problem