SAP Knowledge Base Article - Public

3539844 - Disappearance of CPQ icons on C4C-CPQ integrated environment

Symptom

  • The inability to reopen a CPQ quote after exiting the setup in the Sales Cloud mashup.
  • The option to view the current quote is not visible, leaving no possibility to view the quote.
  • The issue is only occurring on the C4C tenant where CPQ quotes are being accessed. On CPQ standalone, the issue cannot be reproduced.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Connect Sales Cloud to CPQ
  2. Open Opportunities menu in Sales Cloud
  3. Open any Opportunity
  4. Open any Quote
  5. Open the setup of CPQ
  6. Exit the setup
  7. Observe the catalog icon is missing on the top right corner of the page.

Icons before accessing setup:

Icons disappeared after exiting setup:

 "Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Cause

The behavior experienced is default. Once the setup page is exited, the system will naturally navigate to the catalog page. In catalog page only setup icon be visible.

Resolution

The system is working as per design. The icons mentioned are designed to only appear on the quote page. Therefore, once the setup page is exited, the system will naturally navigate to the catalog page.

Keywords

CPQ quote, Sales Cloud, setup, C4C tenant, CPQ standalone, default behavior, catalog page, navigation, Invisible of catalog icon, disappearance of icons. , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions