Symptom
When creating a service order with item category SVPN (Non-billable Service Item), the system still calculates revenue for the item, although the expected revenue recognition should be 0.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Create a service order with item category "Service Product Item (Fixed Price)".
- Change the item category from "Service Product Item (Fixed Price)" to "SVPN (Non-billable Service Item)".
- Checking the "Planned Cost and Revenue" tab of the service order, will find that the "Baseline Planned Revenue" and "Ongoing Planned Revenue" still have values, although the item is expected to be without revenue.
Cause
There are non-zero values in the pricing details. The system always takes prices from pricing conditions.
Resolution
When the item category is changed from "Service Product Item (Fixed Price)" to "SVPN (Non-billable Service Item)", the pricing condition for the non-billable service item also needs to be changed to 0. This adjustment will ensure that the system does not calculate revenue for non-billable service items.
Keywords
SAP S/4HANA Cloud Public Edition, Service order, Non-billable service Item, SVPN, Revenue recognition, Pricing condition, Fixed price , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , CRM-S4-BF-PR-2CL , S4CRM: Pricing (Public Cloud) , Problem