SAP Knowledge Base Article - Public

3540167 - How to disable the user registration email in SAP CPQ

Symptom

Is it possible to disable a user registration email in SAP CPQ?

Environment

SAP Sales Cloud CPQ

Cause

Disabling user registration email in CPQ after using SSO from external system to sign up.

Resolution

If a user is created directly in CPQ (Not via SSO):

  1. Click Setup
  2. Search for "Application Parameters"
  3. in Application parameters, General Parameters tab, you will see a field which is called "Do not email login details to users created by admin:"
  4. This field has a drop down with two values, either True or False
  5. If you set this field to True, you can prevent SAP CPQ from sending emails after registration is complete.
  6. If you set this field to False, regular users (NOT Single sign on) will receive two emails, one with a username and a domain and One email with a URL, which the email recipient needs to use in order to create a password.

However, if the user is created via Single Sign On from an external system.

  1. SSO users don’t receive any emails after they are created, regardless of the selected value of "Do not email login details to users created by admin:" as they are managed by another system, the client’s internal IdP. You can only use Federated Single Sign-On method to log in.

Keywords

CPQ, User Registration, Registration email, email , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ 2024