Symptom
You notice that, upon reaching a phase in your case flow which has an assignment step added as a step e.g. 3rd or 4th step, this assignment step is executed before the other previous steps of the phase are marked as completed.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to your SAP Service Cloud Version 2 environment.
- Navigate to Cases work list.
- Open any case.
- On the case flow, navigate to a new phase which has an Assignment Step added to it as the 3rd or 4th step.
- See that, once you reach the new phase, the assignment step already executes and is marked as completed, even if the initial steps were not set as completed yet.
Cause
For Assignment Steps, if a pre-condition is not defined for it, this step will get processed and executed as soon as the phase in which the step is added is reached on the case.
This is the system designed behavior.
Resolution
In order for the Assignment Step to trigger on a specific time, then you can either:
- Add a pre-condition for your assignment step to execute in the case.
- Let the assignment step be the only step in a case flow phase.
See Also
Keywords
Case, Cases, Case Flow, Case Phases, Case Steps, Steps, Phases, Step, Flow, Phase, Assignment Step, Assignment, Executes, Executed, Automatically, Triggered, Mark as Completed, Completed, Pre-Condition, Condition, Pre, Case Type, SAP Service Cloud Version 2, V2, Version 2, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , How To