SAP Knowledge Base Article - Public

3540579 - Absence does not replaced Regular Working Hours in SuccessFactors negative Time Sheet

Symptom

  • A full-day absence is created for a negative Approved timesheet, but it does not overwrite or remove the regular working hours on the same day as expected.
  • Full day attendance and full day absence exist at the same time without collision error. Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Employee Central - Time Sheet
  • SAP SuccessFactors Time Tracking

Reproducing the Issue

  1. Navigate to an Approved negative timesheet which only has full week attendance generated by the system and no manual records / absence. 

  2. Create a full day absence for any day. 
  3. Observe that system-generated regular working hours are not overwritten or removed by absence as expected.

Cause

The issue happened due to recalculation being in pending status, as the below alert message exists in the time sheet UI:

"The displayed data might not be fully up-to-date because a recalculation is pending for the time sheet."

Resolution

When requesting absence for an Approved negative timesheet, the system triggers event-based recalculation automatically by creating a new Time Management Recalculation Event for current employee from the absence start date. 
 
After recalculation finishes successfully, the system creates a new amendment timesheet as per the Help Document: Recalculation Triggers in the Time Sheet

In the new amendment timesheet, absence replaces system-generated working hours as expected. 

The recalculation may be in Pending status for various reasons, please check the below possible solutions: 

  • From Admin Center, navigate to Manage Data and find the object "Time Management Configuration", then set the field Schedule Immediate Recalculation as "Always". 
    If the field Schedule Immediate Recalculation is "Never", then the newly created Time Management Recalculation Event in "To be Processed" status can only be processed by the daily TLMTriggerRecalculation job. 
  • Navigate to Admin Alerts and check if there's any "recalculate time sheet" alert exists for the employee. 
    If so, please first resolve the error message manually, then trigger manual recalculation again by updating retry counter of the Error Time Management Recalculation Event. 

See Also

Keywords

full-day absence, Regular Working Hours, system generated time, pending Recalculation, negative recorder, time collision , KBA , LOD-SF-EC-TMS , Time Sheet , LOD-SF-TTR-TMS , Time Sheet , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions ; SAP SuccessFactors Time Tracking all versions