SAP Knowledge Base Article - Public

3540785 - Survey Is Not Assigned to Visit As Per Activity Plan

Symptom

Survey is not executed to Visit Plan as per the Activity Assignment rule.

Environment

SAP Sales Cloud and SAP Service Cloud Version 2 

Reproducing the Issue

  1. Go to the Menu.
  2. Open Activity Plan.
  3. Quickly create a new Activity Plan.
  4. Add the respective Survey and click next.
  5. Add or create the Activity Assignment rule with the conditions.
  6. Go back to Menu.
  7. Select Visit entity.
  8. Quickly create a Visit (meeting all the conditions mentioned in the Activity assignment rule).

Issue: There is no Survey added in the Visit automatically, as mentioned in the Activity Plan.

Cause

Survey is not marked/enabled to assign automatically in activity plan.

Resolution

Survey must be enabled for the automatic assignment.

Execute following steps to enable auto assignment of survey

  1. Go to the Menu.
  2. Open Activity Plan entity.
  3. Select and open the saved Activity Plan in detailed view.
  4. Enable the Assign Automatically for all the surveys.

Keywords

Activity plan, Survey, Auto assignment, Visit type assignment , KBA , CEC-CRM-AP , Activity Plan and Activity Assignment Rules , CEC-CRM-VST , Visit for SAP Sales/Service Cloud , CEC-CRM-SUR , Surveys for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions