Symptom
Survey is not executed to Visit Plan as per the Activity Assignment rule.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to the Menu.
- Open Activity Plan.
- Quickly create a new Activity Plan.
- Add the respective Survey and click next.
- Add or create the Activity Assignment rule with the conditions.
- Go back to Menu.
- Select Visit entity.
- Quickly create a Visit (meeting all the conditions mentioned in the Activity assignment rule).
Issue: There is no Survey added in the Visit automatically, as mentioned in the Activity Plan.
Cause
Survey is not marked/enabled to assign automatically in activity plan.
Resolution
Survey must be enabled for the automatic assignment.
Execute following steps to enable auto assignment of survey
- Go to the Menu.
- Open Activity Plan entity.
- Select and open the saved Activity Plan in detailed view.
- Enable the Assign Automatically for all the surveys.
Keywords
Activity plan, Survey, Auto assignment, Visit type assignment , KBA , CEC-CRM-AP , Activity Plan and Activity Assignment Rules , CEC-CRM-VST , Visit for SAP Sales/Service Cloud , CEC-CRM-SUR , Surveys for SAP Sales/Service Cloud , Problem