SAP Knowledge Base Article - Public

3540835 - Search In Agent Desktop Not Returning Results For Extension Field In C4C

Symptom

Searching for a value of an extension field is not returning results in Agent Desktop.

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Open Agent Desktop.
  2. Search for a value of an extension field which is being displayed inside the Agent Desktop.
  3. No results.

Cause

The extension field needs to configured as "searchable" in Settings.

Resolution

  1. Navigate to Administrator workcenter and open the view General Settings.
  2. Scroll down to the end of the page and open the setting "Extensibility Admin UI".
  3. Choose the relevant service.
  4. Make the necessary changes to the field attributes and mark the desired field as "searchable".
  5. Now the Agent Desktop will return results when searching with values from this extension field.

NOTE: This change may take over one hour to reflect. So please wait for some time before testing.

Keywords

Search, Extension, Field, AD, Agent Desktop, C4C, SAP, Result, Record, Empty, Return , KBA , CEC-CRM-SRH , Search for SAP Sales/Service Cloud , CEC-CRM-AD , Agent desktop - live channels , Problem

Product

SAP Cloud for Customer core applications all versions