Symptom
Searching for a value of an extension field is not returning results in Agent Desktop.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Open Agent Desktop.
- Search for a value of an extension field which is being displayed inside the Agent Desktop.
- No results.
Cause
The extension field needs to configured as "searchable" in Settings.
Resolution
- Navigate to Administrator workcenter and open the view General Settings.
- Scroll down to the end of the page and open the setting "Extensibility Admin UI".
- Choose the relevant service.
- Make the necessary changes to the field attributes and mark the desired field as "searchable".
- Now the Agent Desktop will return results when searching with values from this extension field.
NOTE: This change may take over one hour to reflect. So please wait for some time before testing.
Keywords
Search, Extension, Field, AD, Agent Desktop, C4C, SAP, Result, Record, Empty, Return , KBA , CEC-CRM-SRH , Search for SAP Sales/Service Cloud , CEC-CRM-AD , Agent desktop - live channels , Problem
Product
SAP Cloud for Customer core applications all versions