Symptom
- An error occurs when attempting to upload a Bank Statement file in CSV format.
- The error message displayed is: "No bank account active on YYMMDD for account number XYZ, national bank code ABC, and currency DEF found".
- The issue persists despite the bank details appearing to be correct.
(XYZ represents the Bank Account ID)
(ABC represents the National Bank Code)
(DEF represents the currency)
Environment
SAP Business ByDesign
Reproducing the Issue
- Attempt to upload a Bank Statement file in CSV format either via Bank Statements view or File Management - Inbound Files view.
- Maintain the mandatory data as to File Type, Company, Bank ID, Import Format.
- Under Attachments press Add- File.
- Find the file that you want to upload and press Add.
- Start File Upload.
- Error message appears:
No bank account active on YYMMDD for account number XYZ, national bank code ABC, and currency DEF found.
Bank account missing or cannot be determined
Bank statement ID $1 for bank account ID rejected
Cause
The 'My Bank Account ID' field in the CSV file has been filled with "XYZ", which is not a valid in SAP Business ByDesign. This leads to the system's inability to identify a bank account.
Resolution
To resolve this issue, the "Bank Account Number" must be used in "My Bank Account ID" field in CSV file.
- Open the CSV file and locate the 'My Bank Account ID' field.
- Replace the incorrect "XYZ" value with the correct Bank Account Number "AAA" (AAA represents the Bank Account Number).
- Save the changes to the CSV file.
- Attempt to upload the corrected CSV file again.
See Also
Keywords
Bank Statement, CSV file, Upload error, Bank Account ID, Incorrect value, Bank Account Number, Bank account missing or cannot be determined. , KBA , SRD-FIN-CLM , Cash and Liquity Managment , How To