SAP Knowledge Base Article - Public

3542274 - Inability to Modify Address in Manage Customer Master Data due to HCM001 Role in SAP S/4HANA Cloud Public Edition

Symptom

The customer encountered an issue where certain fields could not be modified in edit mode while trying to change employee address information through the APP Maintain Business Partner or Fiori APP Manage Customer Master data. 

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open Manage Customer Master Data.
  2. Search for BP: xxxxx and open it.
  3. Enter into Address details.
  4. See the role HCM001 in Address and select "edit".
  5. Notice that the address cannot be changed.

Cause

The HCM001 role is assigned as the default address type when an Employee Business Partner is created via Successfactors integration. This is seen as the source HR system and the address details can only be changed in Successfactors.

Resolution

  1. If the Employee Business Partner was created locally in the S/4HANA Cloud system, the address details can be updated in the Maintain Business Partner or Fiori APP Manage Customer Master data apps.
  2. If the employee BP was created in SuccessFactors, the address must be maintained there.

See Also

Refer to InfoDoc 208271 / 2021 / Street Address can not be modified via Maintain Business Partner:

https://support.wdf.sap.corp/sap/support/message/002075129400002082712021

Keywords

SAP S/4HANA Cloud Public Edition, Manage Customer Master Data, HCM001 role, address change, Employee Business Partner, SuccessFactors, address details, Maintain Business Partner, Fiori APP. , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions