SAP Knowledge Base Article - Public

3542627 - Submit Button is Disabled on a Sales Order Even After Changes

Symptom

On an Open Sales Order, the Submit button is enabled after making a change on a standard field, but not after a change on an extension field.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Sales Orders workcenter. 
  2. Go to the Sales Orders view. 
  3. Search for the ID ABC (ABC represents the ID of the Sales Order) 
  4. Click on Edit. 
  5. Click on View All. 
  6. On the General tab, enter a new value on the field XYZ (XYZ represents the label of an Extension Field).
  7. The Submit button is still disabled. Now, make a dummy change on any standard field (Example: External Reference field).

The submit button is then enabled.

Cause

Changes on Extension Fields do not trigger the Submit button. A change on a standard field must be performed to activate it.

Resolution

This is the expected system behavior.

Currently there is no functionality for changes on Extension Fields to trigger the activation of the Submit button (as with changes on Standard Fields) on Business ByDesign.

Alternatively, the feasibility of implementing this functionality via an Add-On can be discussed.

It is also possible to submit a new improvement request to add this functionality on SAP Customer Influence website or vote for existing ones.

See Also

KBA 2531827 - Functionality Currently not Available

Keywords

Extension fields, sales order, changes, submit, button, not activated, not triggered, open status, byd. , KBA , SRD-CRM-ORD , Orders & Contracts , How To

Product

SAP Business ByDesign all versions