Symptom
- After rehiring an employee with a new employment, the old employment status becomes active.
- This change in status occurs after the execution of the HRIS Sync job.
- The issue persists even after making a dummy change to the terminated employment, which initially sets the status to inactive. However, after the HRIS Sync job runs, the status reverts to active.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Rehire with new employment a user, using the same User ID and Username, but with lower or upper case.
- Example: if the User ID of the terminated profile is "abc", the User ID of the new employment will be "ABC"
- Check the employee profile - multiple employments are visible for the employee. The old employments are inactive and the new employment is active.
- Login to provisioning - Run the HRIS Sync Job.
- After completion of the HRIS Sync job - Go to the employee's profile and refresh the screen.
- The old employment has become active.
Cause
The HRIS Sync job is not case sensitive, and fetches job records from both user profiles to calculate the delta info, then syncs the user status. This results in the activation of the old employment status.
Resolution
To avoid this issue, please do not rehire a user under new employment with the same ID as the previous employment.
Engineering team is planning to adjust the logic of the HRIS Sync to prevent this kind of problem, but there aren't confirmed dates for that.
See Also
Keywords
SAP SuccessFactors, Employee Central, HRIS Sync job, active status, old employment, rehire, inactive status, job records, delta info, user status, INC10090792 , KBA , LOD-SF-EC-HRS , HRIS Sync , LOD-SF-EC-TER , Termination Details , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , Problem