Symptom
Onboarding processes remain open and visible on the dashboard, even after the Process Close Job successfully runs.
Be sure that you confirmed the following points are already covered:
- Archive rule is configured basing on guide: Setting up a Business Rule for Closing the Onboarding/Offboarding Processes | SAP Help Portal
- Event Reason "No show" is configured accordingly.
- There are no Compliance tasks still pending for affected candidates.
- Job is running in provisioning.
- Job owner has the 'Cancel onboarding' permission.
Environment
SAP SuccessFactors Onboarding
Cause
Affected users have invalid values in the Company/Legal Entity field. It is possible that the corresponding Company objects were deleted after being assigned to these users, resulting in the error during the Process Close Job.
Resolution
The process closure job evaluates and processes objects in batches. If any errors are present within the batch, they can prevent the successful closure of all processes in that group. Here's an overview of how the process closure job works:
- Batch Selection: The job selects up to 100 eligible processes (default batch size) for closure, based on the defined closure period.
- Validation: It checks if there are any open compliance tasks or related processes for each record.
- Batch Update: All processes in the batch are updated and saved together. If any error occurs with even one process in the batch, none of the updates are saved.
Since all processes are saved together, a single error can impact the entire batch. In this case, some records in the batch encountered issues, which prevented the other processes from being closed. This explains why the process in question still appears on the dashboard—it is grouped with other processes that have unresolved errors.
For this matter, only one or some users might be blocking the entire Archive process, and the following error message will be found in Internal Logs: "This record was not saved because there were errors in other records for 12345. : ECT_service_layer_PROPAGATE_ERROR_FOR_SUBJECT_USER"
In order to identify the affected candidates, please open a case with Onboarding side in component "LOD-SF-OBX-JPC" and please provide:
- This KBA as reference
- Evidences of points raised in "symptom' were checked (screenshots)
Support Engineers, please check the internal memo.
See Also
Keywords
archive, archiving, rule, job, closure, close, onboarding, process, still, open, appear, dashboard, This record was not saved because there were errors in other records for, ECT_service_layer_PROPAGATE_ERROR_FOR_SUBJECT_USER, OBX, 2.0 , KBA , LOD-SF-OBX-JPC , Process close job , Problem
Product
Attachments
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