Symptom
The error message "Gender does not match the title" appears when attempting to create or edit a contact.
Environment
- SAP Sales Cloud Version 2
- SAP Sales and Service Cloud Version 2
Reproducing the Issue
- Open the navigation menu.
- Select the Contact view.
- In the Contact view, click on New.
- Fill in the Title field (e.g., select Ms.).
- In the Gender field, select a value (e.g., Gender not known).
- Attempt to save the contact.
- The error message appears: "Gender Gender not known does not match the title ..."
Cause
This issue occurs because the Title selected is linked to a specific Related Gender Code in the system settings.
Resolution
To resolve this issue, check the Title settings in the system:
- Open the User menu.
- All Settings.
- Search and Open Title under Business Partners section.
- Locate the Related Gender Code column for the title in question.
- Ensure that the Related Gender Code field for the title is either:
- Left empty (to allow all gender options), or
- Includes all desired gender codes (Male, Female, Gender not known, etc.).
After adjusting the settings, you will no longer encounter this error when creating contacts with mismatched title and gender combinations.
Keywords
Error, does not match, Gender, Title, Contact, Business Partner, Sales Cloud Version 2, CNS , KBA , CEC-CRM-CON , Contact for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0