SAP Knowledge Base Article - Public

3542918 - Can't search and add a technical role to the technical user

Symptom

When searching for an existing technical role, no results are displayed.

Environment

  • SAP Sales Cloud Version 2
  • SAP Service Cloud Version 2
  • SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Go to the User Menu
  2. Click the Settings
  3. Search Users in All Settings
  4. Click it and switch the user filter to Technical user
  5. Click the technical user that wants to assign the technical role
  6. In the user detail - Assigned Technical Roles tab, search the technical role name or role ID by search and add button
  7. No result display

Cause

Any standard role assigned to the communication user can not be assigned to the user.

Resolution

Please create a technical role first and try to assign that role to the technical user with the steps below.

  1. Go to the Users and Control - Role in all settings
  2. Click the Roles tab
  3. Switch the filter to Technical Roles
  4. Click the "+" Button to create
  5. Maintain the Role name and description
  6. Enable the Business Services and the Admin Option
  7. Save and active it
  8. Go back to Users
  9. Choose the technical user
  10. Search the technical role and assign it to the technical user

See Also

Keywords

CNS; Technical Role; Search; User , KBA , CEC-CRM-IAM , Identity and Access Management for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions