SAP Knowledge Base Article - Public

3543334 - Your User Activities log is almost full in SAP Datasphere

Symptom

Users who have Delete Permission for Activity Log in SAP Datasphere start receiving the e-mail:

Your User Activities log is almost full.

The size of your User Activities log approaches its limit. There is only xx.yy% free storage space left. When the User Activities log will reach its limit, the oldest entries will be deleted from the system to keep the log size below the limit.

Environment

SAP Datasphere

Cause

When the activity log approaches the defined limit (default: 500,000 rows), the users who have Delete permission will receive an e-mail and an alert notification. Further alerts will be sent if the log continues to grow closer to the limit.

Resolution

  • When the activity log reaches the limit, final notifications are sent, then oldest rows are permanently deleted to keep the log size below the limit.
  • In case the logs are required, you can download part or all as CSV files, and then delete the log entries from the system.
  • Furthermore, you can request the limit number of rows to be changed to a higher number, or changed to a one-year rolling period.
    For that, create a support ticket under the component DS-SEC. Make sure to include this KBA Number as reference.
    Once the Activity log limit is adjusted, it will be applied to current and new log activity.  

Keywords

ACTIVITY_LOG_TIME_LIMIT , KBA , DS-SEC , Security (Users, Roles) , Known Error

Product

SAP Datasphere all versions