SAP Knowledge Base Article - Public

3543374 - Contact's e-mail appears in Lead OWL but not in header

Symptom

The contact's email is displayed on Leads OWL, but when opening the Lead, the E-mail field is empty.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales > Leads.
  2. Search for the desired Lead.
  3. See 'E-mail' column has the contact's e-mail filled.
  4. Now open the Lead — see e-mail field is empty.

Cause

An e-mail address was not maintained for the contact in the "Account Section" under the "Contact Tab." As a result, users are unable to see it in the header, even though it appears on the OWL screen. This issue arises because the binding paths for the e-mail are different between the OWL and header:

  • /Root/EmailURI is used for the header screen.
  • /Root/DataList/EmailURI is used for the OWL screen.

Resolution

To maintain the e-mail address, please follow the steps below:

  1. Open the Lead > Click to open the Account.
  2. Go to Contacts facet.
  3. Maintain the e-mail for the desired contact.

Keywords

Email, does not show, doesn't show, is not showing, is not appearing, blank , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer core applications all versions