Symptom
The contact's email is displayed on Leads OWL, but when opening the Lead, the E-mail field is empty.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales > Leads.
- Search for the desired Lead.
- See 'E-mail' column has the contact's e-mail filled.
- Now open the Lead — see e-mail field is empty.
Cause
An e-mail address was not maintained for the contact in the "Account Section" under the "Contact Tab." As a result, users are unable to see it in the header, even though it appears on the OWL screen. This issue arises because the binding paths for the e-mail are different between the OWL and header:
- /Root/EmailURI is used for the header screen.
- /Root/DataList/EmailURI is used for the OWL screen.
Resolution
To maintain the e-mail address, please follow the steps below:
- Open the Lead > Click to open the Account.
- Go to Contacts facet.
- Maintain the e-mail for the desired contact.
Keywords
Email, does not show, doesn't show, is not showing, is not appearing, blank , KBA , LOD-CRM-LM , Lead Management , Problem