SAP Knowledge Base Article - Public

3543888 - Solve Document Inconsistency in Invoice Request message referring to unknown Invoice ABC Sent by Supplier

Symptom

Many business tasks are being created with the subject: "Solve Document Inconsistency in Invoice Request message referring to unknown Invoice ABC Sent by Supplier" (ABC is the Customer Invoice Cancellation's ID). 

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Application and User Management work center.
  2. Go to Business Task Management view.
    There is one or more open tasks with the subject "Solve Document Inconsistency in Invoice Request message referring to unknown Invoice ABC Sent by Supplier"
  3. Open the task and see its description:
    - An error occurred:
    - Canceling invoice XYZ not possible; invoice not determined (XYZ is the Customer Invoice's ID)
    - Execute the task and follow the solution proposal to solve the error. 

Cause

The original Customer Invoice XYZ has the Output Channel as E-Mail and Printer. The Cancellation Invoice ABC has the Output Channel as XML and Printer. If a Cancellation Invoice has the Output Channel XML, this means that it is an intercompany invoice (or a third-party invoice) and a Process Message is created which automatically cancels the Intercompany Supplier Invoice.

Since the original Customer Invoice XYZ has the Output Channel as E-Mail and Printer, no Supplier Invoice was created. Hence when the system tries to cancel the Supplier Invoice via the process message of the Cancellation Invoice ABC, the Process Communication Error “Canceling invoice XYZ not possible; invoice not determined” occurs.

Because of that a failed message was triggered in the backend and also the open tasks in the front-end. 

Resolution

Please create a case with your permission to cancel the failed message in the backend. 

Once the failed message is corrected, the task can be completed, and the tasks will no longer appear in the 'Open Errors with Tasks in the Process Communication Error' view anymore.

For future - this can be avoided by checking the Output Settings before the Cancellation Invoice is released and ensure that the Output Channels are the same as in the Original Invoice.

Keywords

Solve Document Inconsistency in Invoice Request message referring to unknown Invoice; Customer Invoice; Invoice Cancellation; Supplier Invoice; Output Channel , KBA , AP-CI-CI , Customer Invoice , How To

Product

SAP Business ByDesign all versions