SAP Knowledge Base Article - Public

3543928 - Unable to set Last Name field as non-mandatory on Individual Customer/Contacts creation screen

Symptom

It is desired to set 'Last Name' field as non-mandatory on Individual Customer or Contacts creation screen.

It was also noticed there is an option available in Adaptation Mode. But even after unchecking the 'Set as mandatory' option for 'Last Name' field, it remains set as mandatory.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers > Individual Customers.
  2. Click on new.
  3. See Last Name field is mandatory.
  4. Go to Adaptation Mode > right-click on the field.
  5. On Overview tab, uncheck the Set as Mandatory.
  6. Close Adaptation.
  7. Notice the field remains mandatory.

Cause

The 'Last Name' field is a mandatory field by default on Individual Customers and Contacts quick create view and cannot be changed via adaptation mode.

Resolution

This is the expected system behavior.

Keywords

KBA , LOD-CRM-ACC-PRI , Private Account (Customers) , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer core applications all versions