SAP Knowledge Base Article - Public

3545024 - OData Will Create But Not Send Email Record

Symptom

Customer creates a email record via OData and expects it to be sent.  

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Post an email via OData.
  2. Check that it is created, but not sent.

Cause

By using OData POST the system will perform the creation of e-mail activities in C4C only, meaning, these actions will be just a register of received e-mail and not actually have one being sent out.

To achieve this, then a BO action must be triggered here, which can be achieved through a PDI logic.

OData in this scenario is only meant for creation of e-mail activities in C4C. In this case, if email needs to be sent, then "Send" BO action must be triggered here otherwise, it will just create the activity without triggering an outbound e-mail. 

Resolution

It is possible to access our Influence Portal and suggest an improvement in this scenario if you believe it could best serve your business purposes: https://influence.sap.com/sap/ino/#/campaign/1868

See Also

Help portal

Keywords

Post; create; email; odata; send; activity; outbound.  , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Product Enhancement

Product

SAP Cloud for Customer core applications 2411