SAP Knowledge Base Article - Public

3545255 - Excessive digits registered for Business Phone during Employee Import

Symptom

When performing a Basic Import via Import Employee Data, the Business Phone number is updated with more digits than the maximum length configured in Manage Business Configuration.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to Import Employee Data.
  2. In the Select an entity dropdown, choose Basic Import.
  3. Click on Browse… to upload the import file.
  4. Click on Import.
  5. Verify that the import result is successful.
  6. Export the User Data File (UDF) in Employee Export and observe that the Business Phone number column contains more digits than the maximum length specified in Manage Business Configuration.

Cause

The system does not validate the maximum length of the Business Phone during Employee Import, allowing the acceptance of excessive digits.

Resolution

Use the EC personal info Import function to import the phone number and run HRIS sync to synchronize the updated information to the Employee Profile (EP) side.

Keywords

Employee Import, Import Employee Data, Business Phone, Maximum Character Limit, Excessive Digits , KBA , LOD-SF-PLT-UIM , Employee Import Issues , Problem

Product

SAP SuccessFactors HCM Suite all versions