Symptom
You would like to hide all tabs, such as Similar Cases and Knowledge Base in the case right panel, however, upon trying to do so, you receive the message You must retain at least one visible section to add more sections.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to your SAP Service Cloud Version 2 tenant.
- Navigate to Cases work list.
- Open any case.
- Click on the User Profile.
- Click Start Adaptation.
- Click to edit the right panel of the case.
- Try to hide all tabs such as Similar Cases, Knowledge Base and custom tabs.
- See the pop-up You must retain at least one visible section to add more sections.
Cause
It is currently not possible to remove / hide all sections, as by standard, at least one section needs to be retained visible in order to be able to add more in the future.
Resolution
This is the system designed behavior.
A potential workaround to remove / hide standard tabs such as Similar Cases and Knowledge Base, would be to create a custom dummy tab and keep it visible.
Keywords
Case, Cases, Right Panel, Similar Cases, Knowledge Base, Tab, Tabs, Case Tabs, Similar Cases Tab, Knowledge Base Tab, Hide, Remove, Remove Tab, Hide Tab, You must retain at least one visible section to add more sections, sections, SAP Service Cloud Version 2, V2, Version 2, , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM , Customization for SAP Sales/Service Cloud , How To