Symptom
How to add new attachment types in attachment upload.
Environment
- SAP Sales Cloud V2
- SAP Service Cloud V2
Reproducing the Issue
1. Go to the Business Object where it will be made the upload, e.g. Cases.
2. Open any item of the list and go to "General" Tab.
3. Scroll Down until see the Attachment session.
4. Click on "Drop Or Browse Files" and select the desired file.
5. After adding, the file will be marked as "Standard Attachment" and in the "Attachment Type" list there will be only default attachments.
Cause
By default some Attachment Type are select to appear in the system.
Resolution
To add new attachment types, follow the steps below:
1. Login as Admin.
2. Navigate to "Settings" > "All Settings".
3. Search for "Attachment Types" and create the desired type.
Note: it's required to create the code and description for the new type.
4. Go back to the "All Settings" tab and search for "Attachment Types Assignment".
5. Select the business object where it's required to add the new type.
6. In the list, select the correct type and save.
7. Go to the business object screen, open the item, navigate to the "General" tab and scroll down to the "Attachment" session.
8. When selecting the file, in the "Attachment Type" list, the new type assigned will appear.
Keywords
Attachment, Attachment Type, Assignment Type, Settings, Upload , KBA , CEC-CRM-DOS , Document Service for SAP Sales/Service Cloud , How To