Symptom
- An error occurs when attempting to migrate SEPA mandates for customers using the migration tool in Business ByDesign.
- The error message displayed is "Service call failed; report an incident".
- The issue arises when trying to update data about the method of payment and mandate for several hundred customers who already have bank data in the system.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Navigate to Business Configuration work center.
- Then go to the Overview view.
- Search for the activity "Migration of Customers" and open it.
- Click "Migrate customers using the migration tool".
- Select the affected template.
- Click "Execute Migration Step by Step".
- The error message will appear at the "Simulate Import" step.
Cause
There are two possible causes for this error in the Migration of Customer:
- SEPA Creditor ID is missing at company level.
- Missing account determination group for customer and company.
Resolution
- For the first cause, please maintain the SEPA Creditor ID at company in the org level.
- You can maintain this data in the Organitional Management work center.
- Select Company.
- Click Edit.
- Go to the General tab.
- Hyperlink External Identifier.
- Enter account determination group for customer and company.
As per the logic system is throwing message when 'Cash on Demand' is not scoped in the Business Configuration.
See Also
2420304 - Unable To Modify Contact Information Using Migration Tool
3254075 - Error "Service Call failed; Report an Incident" When Trying to Migrate Contacts
Keywords
Migration of Customers, SEPA mandates, Customers, Accounts, Company, Error, Service call failed, Migration tool, Method of payment, Mandate, Simulate Import. , KBA , AP-BP-BP , BusinessByDesign: Business Partner , How To
Product
SAP Business ByDesign all versions