SAP Knowledge Base Article - Public

3546216 - Picklist not appearing in dropdown when configuring a field in Manage Business Configuration - Employee Central

Symptom

Not possible to find the picklist in dropdown when configuring a field in Manage Business Configuration.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Navigate to Manage Business Configuration;
  2. Navigate to the field which the picklist will be added;
  3. Select Details;
  4. Search for the picklist of interest by it's name/code in the 'Picklist' Dropdown;
  5. It won't appear in the dropdown.

Cause

What appears in the Picklist dropdown is the 'Legacy Picklist ID', not the Picklist name or code.

Resolution

Select the Picklist searching by 'Legacy Picklist ID'.

In Picklist Center:

In BCUI:

See Also

3541778 - Picklist options are not showing in Onboarding 1.0 - SAP for Me

2909791 - Picklist codes appended with suffixes "~%1", "~MDF" or "~LEGACY" - Post Picklist Migration - SAP for Me

Keywords

INC10036363, picklist, Legacy Picklist ID, Manage Business Configuration, BCUI, field, custom, code, picklist name, picklist center, appearing , KBA , LOD-SF-EC-BCI , Manage Business Configuration (BCUI) & Data Models (XML) , LOD-SF-EC-JOB-PKL , Picklists , LOD-SF-PLT-PCK , Picklist Management Issue , LOD-SF-MDF-PKL , Picklists , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions

Attachments

Pasted image.png
Pasted image.png