SAP Knowledge Base Article - Public

3546671 - Product Category disappears on the Shopping Cart screen

Symptom

You have created a shopping cart with free text items and released it . Later you can see the product category field is showing blank.

Environment

SAP Business By Design

Reproducing the Issue

  1. Go to Business Analytics work center

  2. Select report: Shopping Cart Tracking

  3. Open the respective Shopping Cart

  4. Select view all

  5. Navigate to Items tab

  6. At the right end , there is a product category field->It shows empty .

    If you click on each line item, it will show the product category name.

    Again if you close and open the document, the field will show empty.

Cause

1. The Design and fact sheet technical mapping for the overview screen is built in a way to display all the line item's product category in one Go.

2. Whereas in the View All screen, upon the default line-item selection, the very first line of product category is displayed. Subsequently upon all other item line selections, rest of the row entries are visible. 

The system is picking the first selected line-item as default for Product category fetching and mapping to UI data model. 

Subsequently the next line selection will trigger the backend for next selected line-item's product category fetch. 

Resolution

This is expected system behavior for the View all screen.

Note:

For improving query performance, the view all screen mapping is different.

Keywords

product category missing in shopping cart , KBA , AP-REQ-IR , Internal Request , SRD-SRM-PRO , Purchase Requests and Orders , Problem

Product

SAP Business ByDesign all versions