Symptom
- Missing country Under Personal Information
-
You would receive an application error when updating personal Information ,The application error id would be accompanied by Error: messageKey = "ECT_service_layer_HRIS_IMPORT_COUNTRY_NOT_IN_CSF_SDM and Please specify the country/region in the country/region Specific data model
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central - Employee Central - Personal Information
Reproducing the Issue
Example County Brazil User
- Go to test user
- Personal Information section
- Select edit
- Scroll down to Global Information Country/Region
- Select Country/Region dropdown
- Result: Countries missing in the dropdown for Personal Information portlet : example country Brazil.
Cause
It is currently not supported to disable the globalInfo element
- Data issue in the Global Information element: with an Adhoc report in domain Person and Employment Export, You could observe that there is Global Information data for this employee, but this is not visible in the interface but can be see data inspector Table_PER_PERSON_INFO_GBL_T , most likely because there is no configuration for test country from Manage Business Configuration > globalInfo > Country/Region specific section.
Example of Issue
Issue 1: Test user global information was maintained before disabling Global Information (globalInfo) Via BCUI or CSF data model
- Go to Data inspector
- Table_PER_PERSON_INFO_GBL_T
- Users Sys ID =
Issue 2: disabling Global Information (globalInfo) Via BCUI or CSF data model
Example: Brazil : It seems customer hasn't enabled global info for BRA.
Resolution
To resolve, Please enable global info for your specific country and Grant relevant permission properly
Also
You can delete the Global Information data for this employee with an import Via Import : 2236017 - Mass Deletion of MDF Data via Import.
Steps:
- Report Center > Person and Employment Export report > select the fields under "Person Info Global" and filter by employee:
- Import Employee Data > download the template for Global Information;
- Fill in the template with the data extracted from the report;
- Fill the "Operation" column with "DELETE".
- Import the file.
The import to Personal Information should work now
Very Important Note: It is currently not supported to disable the globalInfo element : 2472927 - It is not possible to disable Global Information Element - Employee Central
- Do not disable any country Global Information (globalInfo) when some user globalInfo record have been maintained Via UI or Import
- This may cause some data issues
-
It is currently not supported to disable the globalInfo element.
This can cause unexpected behaviour and errors, in any portlet for which you have configured Country Specific Fields (CSF) including: Job Information, Home Address, Personal Information and National Id Information.
FAQ - Additional Information
Q) Where can I get information on this from the Guide?
A) Guide:Data Model Field Information for Employee Central -
See Also
- 2533354 - Missing field in global info portlet
- 3283107 - When saving personal information, application error pops up
- 2533354 - Missing field in global info portlet
- 3066117 - How to export Data Models?
- 2651585 - Manage Business Configuration: How to Generate Business Configuration Audit logs via Manage Scheduled Jobs
- 2236017 - Mass Deletion of MDF Data via Import
Keywords
ECT_service_layer_HRIS_IMPORT_COUNTRY_NOT_IN_CSF_SDM, ERROR, Please specify the country/region in the country /region Specific, Incident, INC10206288,INC3780235 ,Table_PER_PERSON_INFO_GBL_T, data inspector, BCUI, CSF data model, global info, Territory Id , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , LOD-SF-EC-PER-GLO , Global Info - Config, Rules, RBP, UI , Problem