SAP Knowledge Base Article - Public

3547412 - Error when creating live connection to SAP HANA Cloud in SAC

Symptom

Error on screen:

  • "We couldn't connect to your HANA system. Possible causes: The SSL certificate is not trusted, or a network error occurred. For more information, see troubleshooting page". 

Error in console log:

  • GET https://<SAC tenant>/lcs/hanacloud/HANADB/sap/bc/ina/service/v2/GetServerInfo 500 (Internal Server Error)

Error in HAR trace:

  • Failed to retrieve remote response with external exception: SAP DBTech JDBC: Cannot connect to jdbc:sap://<HANA Cloud host>.hanacloud.ondemand.com:443 [Object is closed: com.sap.db.jdbc.SecureChannelSession@<HANA Cloud host>.hanacloud.ondemand.com:443 ConnectionID:0 SessionID:0 on sun.nio.ch.UnixAsynchronousSocketChannelImpl[connected local=/<IP> remote=<HANA Cloud host>.hanacloud.ondemand.com/<Remote IP>:443]: <IP> -> <HANA Cloud host>.hanacloud.ondemand.com:443 ConnectionID:0 SessionID:0].

Environment

  • SAP Analytics Cloud

Reproducing the Issue

  1. Create a live HANA Cloud type connection in SAC.
  2. Enter the HANA host and user name and password.
  3. Click Save button in the connection page.

Cause

The SAC tenant IP is not in HANA Cloud allowlist. See IP Allowlisting 

Resolution

  1. Check your SAC tenant IP list from https://help.sap.com/docs/btp/sap-business-technology-platform/regions-and-api-endpoints-available-for-cloud-foundry-environment by filtering your SAC tenant region, eg: eu10 or us10, etc.
  2. Add all the NAT IPs to your HANA Cloud allowlist. See 3396818 - How to add specific IP address to allowlist 

See Also

  • 3396818 - How to add specific IP address to allowlist 
  • 3296705 - Got error "We couldn't connect to your HANA system. For more information, see our troubleshooting page." when create a live HANA Cloud type data connection to HANA Cloud in SAP Analytics Cloud
  • 2459838 - What Internet Protocol (IP) ranges does SAP Analytics Cloud occupy? 

Keywords

KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud 1.0