SAP Knowledge Base Article - Public

3547544 - Status Profiles for Sales Order Line Items in SAP S/4HANA Public Cloud Edition

Symptom

System status option not available in sales order line item in SAP S/4HANA Public Cloud Edition.

Environment

S/4HANA Public Cloud Edition.

Reproducing the Issue

  1. Create sales order.
  2. Save sales order.
  3. Click Display header details.
  4. Navigate to Status tab.
  5. No System Status field visible.

Cause

In ECC, the System Status at the line-item level was derived from status tables VBUK (header) and VBUP (item). However, in SAP S/4HANA Public Cloud Edition, these tables have been eliminated as part of SAP's data model simplification. The status fields are now directly integrated into the respective document tables:

  • VBAK (Sales Order Header)
  • VBAP (Sales Order Item)
  • LIKP/LIPS (Delivery Header/Item)
  • VBRK (Billing Document Header)

Resolution

  • Switch to Flexible Approval Workflows: In SAP S/4HANA Public Cloud Edition, status profiles are replaced by flexible approval workflows.
  • Configure Approval Workflows: Use the "Manage Sales Document Workflows" app to configure the approval workflows.

See Also

Keywords

SAP S/4HANA Public Cloud Edition, S/4HANA, Cloud, Sales Order, Item, Sales, Order, System Status, Status Profile, User,  ECC, tables, VBAK, Sales Order Header, VBAP, Sales Order Item, VBUK, Header Status Table in ECC, SAP Help Portal, Sales Documents, Sales Document Workflows, Workflows, Flexible Workflows, Workflows for Sales Documents, Approval Workflows, Status, Status Management, Sales Order Status Management. , KBA , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions