SAP Knowledge Base Article - Public

3547548 - Error "Failed to deactivate the following users because they do not exist: [xxxxx]" when importing data through employee import

Symptom

When trying to import users, an error message is received in the e-mail notification stating "Failed to deactivate the following users because they do not exist: [xxxxx]."

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

SAP SuccessFactors HCM Suite

Reproducing the Issue

Process an employee import manually.

Cause

If UserID consists of numbers, there is a possibility that the UserID format is incorrect. Please check the UserID.

Resolution

  1. Export Employee file
  2. Open the file via NotePad and check the UserID format. The UserID is "0000xxxx" in NotePad, but UserID is "xxxx" without "0000" in Excel. Please refer to the picture 1 for details.
  3. If you open the file via Excel, please follow the steps below to correct the format in Excel. Please refer to the picture 2 for details.
    • Step 1. Select the UserID column. 
    • Step 2. Right-click and choose "Format Cells...".
    • Step 3. Under "Number -> Custom", type the corresponding number of 0s in the Type field. Then the UserID format will be correct. 
    • Step 4. Save and upload to the system.

picture 1: this picture shows the difference between opening with NodePad and opening with Excel.

picture 2: This picture shows how to correct the UserID format in Excel.

 

Keywords

SAP SuccessFactors Platform, user update, error, users do not exist, failed to deactivate, Employee Import Issues. , KBA , LOD-SF-PLT-UIM , Employee Import Issues , How To

Product

SAP SuccessFactors HCM Suite all versions