Symptom
- When attempting to import users via Employee Import, an error message is received via email notification stating: "Failed to deactivate the following users because they do not exist: [xxxxx]."
- When trying to inactivate users via Employee Import function, an error message is received via email notification stating: "Failed to deactivate the following users because they do not exist: [xxxxx]."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Go to Import Employee Data.
- In the Select an entity dropdown, select Basic Import.
- Click on Browse… to upload the import file.
- Click on Import.
- Check the import result received by email and notice that the active user did not have its status changed to inactive. There is an error message: "Failed to deactivate the following users because they do not exist: [xxxxx]."
Cause
The User ID that you are trying to change the status from active to inactive does not exist.
Resolution
Ensure that the User ID you are trying to change the status from active to inactive exists:
- Go to Employee Export.
- Click on Export User File.
- Once the download is ready, open the User Data File (UDF) in Notepad or Notepad++. This ensures that any leading zeros on the User ID are not removed, as might happen if the file is opened using Excel.
- After confirming the User ID, update the import file and proceed with the import again.
See Also
Keywords
SAP SuccessFactors Platform, user update, error, users do not exist, failed to deactivate, Employee Import Issues, leading zero. , KBA , LOD-SF-PLT-UIM , Employee Import Issues , How To
Product
SAP SuccessFactors HCM Suite all versions
SAP Knowledge Base Article - Public