Symptom
While generating summary in Ticket, error shows as 'Document cannot be generated; ADS server returned an SOAP error'.
Environment
SAP Cloud for Customer core applications
Reproducing the Issue
- Go to Service Work Center.
- Open Tickets Work Center View.
- Open Ticket 123(where 123 is the ID of the Ticket).
- Click on Actions and select Generate Summary option.
- In the pop-up, select a form template and click on Generate.
Notice that the screen loads for sometime and error occurs as- 'Document cannot be generated; ADS server returned an SOAP error'.
Cause
This error message means that the document XML which the Ticket application generates for the output is too large and the ADS server is unable to process it. This can happen, for example, when there are too many Interactions with multiple Inline images in it.
Resolution
In order to resolve the issue, follow the below steps:
- Go to Administrator Work Center.
- Navigate to Service and Social Work Center View.
- Open Ticket Configuration.
- In Output Management section, enable the 'Disable Interactions' option and disable the 'Enable Inline Images' option.
This will ensure that Interactions and Inline images are not included in the generated Ticket summary.
See Also
Keywords
ADS, SOAP Error, Ticket, Summary, Preview, Document, Form Template. , KBA , LOD-CRM-SRP , Service Request Processing , AP-RC-OUT , Output Management , Problem