SAP Knowledge Base Article - Public

3548208 - Cloud Application Studio Solution content sync issues in different Landscapes

Symptom

Latest Patch Version Content Folders are not in sync between Development, Quality and Production systems in the Cloud Application Studio.

Environment

SAP Cloud for Customer
SAP ByDesign 

Reproducing the Issue

  • Go to Cloud Application Studio
  • Open Development Source system
  • Open Solution and see all folders of latest Patch version are visible
  • Now open same in QA or PRD, even the latest same Patch is deployed content folders are missing in QA and PRD

Cause

This is caused by the Cache files stored in the Project folder on your local system.

Resolution

To resolve the Cache files, please follow the below steps:

1.Right-Click the Solution name under Project Explorer and select Open Folder in File Explorer.
2.Close the Cloud Applications Studio.
3.Back in the File Explorer, navigate up to the System Name.
4.Delete the folders associated with the Solution ID.
5.The default Projects location is: C:\Users\_USERNAME_\Documents\Visual Studio 2015\Projects

The folders will be re-created with the most recent Solution Data from the SAP back end the next time the Solution is loaded.

OR

  • Login to the Repository 
  • Create new system and ID combination with URL
  • Login again to Cloud Application Studio

Issue should be resolved.

Keywords

Sync issue, Repository issue, folder issue, CAS, Inconsistencies in SDK. , KBA , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem

Product

SAP Cloud for Customer core applications all versions