SAP Knowledge Base Article - Public

3548412 - Issues with changing Job Information fields in History UI 2H2024 – Employee Central

Symptom

When a change is made to a field via the Job Information History UI (e.g. Company), the Country of Company field does not automatically populate, and the onChange rules are not triggered, with no entries appearing in the rule trace logs. However, this issue does not occur when changes are made through MSS or the Edit Job Information feature via the pencil icon.

Environment

  • SAP SuccessFactors Employee Central
  • SAP SuccessFactors HCM Suite

Reproducing the Issue

  1. Go to any user profile.
  2. Navigate to Job Information History.
  3. Click on Insert New Record.
  4. Change the Company field.
  5. Notice that the Country of Company field does not auto-populate with the corresponding country.
  6. Notice that no rules are triggered. Download the trace and observe that the rules are not logged.

Cause

This is a system limitation.

Resolution

Product Engineering confirmed that a fix is planned for 1H2026 release.

  • Workaround: change the field from ESS/MSS: Take Action > Change Comp and Job info.

Note: click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs.

See Also

Keywords

2H2024, KI2411, b2411, INC10270305, Job Information, onChange Rules, Country, country-of-company, not triggered, blank rule trace, employee central, successfactors, ECT-258147 , KBA , LOD-SF-EC-JOB-UI , History UI & MSS UI , Bug Filed

Product

SAP SuccessFactors Employee Central 2411 ; SAP SuccessFactors HCM Suite all versions