Symptom
You are replicating Registered Products from S4HANA to Sales & Service Cloud v2 and it fails with error "JSON parse error" in the Message Monitoring.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Sales & Service Cloud v2 Integration with SAP S4HANA
Cause
Sending Warranty ID with Start Date & End Date is mandatory in Sales Cloud V2. However in some cases, you may not have warranty master in S4 and you directly maintain Start & End Dates.
Resolution
Follow the below steps to create a warranty without duration in V2 and use Pre-Hook determination to consider this warranty during registered product creation/ replication.
Step 1 : Create a Warranty without duration and get the ID from developer tools like shown below
Step 2 : In Extensibility Administration, create and activate a determination for Registered Product as shown below. Use the id of warranty that was created in previous step as shown below.
Step 3 : Write the determination conditions as mentioned below
Step 4 : This Pre Hook determination will automatically fill in the Warranty id if Warranty id is not passed and start date and end date are present. So with the incoming message from S4HANA , this pre-hook will determine the warranty that we have created in 1st step and includes it during the warranty creation.
This will also work if you directly consume the registered product service api from an external source as well as when you dont fill warranty id but fill only start and end dates on UI.
Keywords
"Registered Product Replication" ; "Warranty" ; "Warranty Master unavailable in S4HANA" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , CEC-CRM-WAR , Warranty for SAP Sales/Service Cloud , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , Problem