Symptom
When replicating tickets from C4C to ERP, you notice that the language code is wrong, or that several language codes are transferred.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Work center Administrator, view Web Service Message Monitor.
- Search for the respective message that shows the transferred ticket data.
- Click View > Payload.
- Search via Ctrl+F for languageCode -> you will see that some entries are sent with English as the language, and some with another language for example.
Cause
There are 2 languages that are relevant for the integration scenario.
Resolution
The first is maintained in the business configuration, in the Fine Tuning activity "Communication Language for Data Replication". This determines the correspondence language.
However name fields are determined by the language in the respective object, in this case, a ticket. This language is filled at the time of ticket creation, always according to the login language - eg. if you are logged in with German language and create a Ticket, names will be saved as German language.
If a ticket is created by email, it will be created by a technical user and the language for these user will be set as English.
Keywords
ticket, language, erp, language code, integration, cases, service , KBA , LOD-CRM-SRP , Service Request Processing , How To