SAP Knowledge Base Article - Preview

3549753 - javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target; No available router to

Symptom

After performing support pack update, JMS receiver channel is failing with the following error:
[EXCEPTION]
javax.naming.CommunicationException: Failed to initialize JNDI context, tried 2 time or times totally, the interval of each time is 0ms.
XXXXXXXXXXXXXXXXXXXXXX: Destination XXX unreachable.; nested exception is: 
javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate); No available router to destination.; nested exception is: 
java.rmi.ConnectException: No available router to destination. [Root exception is java.net.ConnectException: XXXXXXXXXXXXXXXXXXXX: Destination XXX unreachable.; nested exception is: 
javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate); No available router to destination.; nested exception is: 
java.rmi.ConnectException: No available router to destination.]
(..)
at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:302)
Caused by: java.net.ConnectException: XXXXXXXXXXXXXXXX: Destination XXX unreachable.; nested exception is: 
javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate); No available router to destination.; nested exception is: 
java.rmi.ConnectException: No available router to destination.
(..)
at weblogic.jndi.WLInitialContextFactoryDelegate.getInitialContext(WLInitialContextFactoryDelegate.java:350)
... 21 more
Caused by: java.rmi.ConnectException: Destination XXX unreachable.; nested exception is: 
(..)
... 27 more
Caused by: java.rmi.ConnectException: No available router to destination.



Read more...

Environment

SAP NetWeaver 7.50

Keywords

certificates, jre/lib/security/cacerts, restart, SP Level update,JMS, JMS receiver channel, connection exception, target URL, javax.naming.CommunicationException, JNDI context, SSLHandshakeException, protocol disabled, cipher suites inappropriate, router unavailable, java.rmi.ConnectException, weblogic.jndi, JNDI initialization, sapjvm , KBA , BC-XI-CON-JMS , JMS Adapter , Problem

About this page

This is a preview of a SAP Knowledge Base Article. Click more to access the full version on SAP for Me (Login required).

Search for additional results

Visit SAP Support Portal's SAP Notes and KBA Search.