Symptom
- An error message "error code: 10021: company id is not present in request@sf_init" is received when attempting to open an external URL
- When using the SuccessFactors Mobile App, if you click on a custom card (third-party), it opens in a mobile browser and displays an error.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors Mobile
- SAP Build Work Zone, Advanced Edition
- SAP SuccessFactors Work Zone
- SAP SuccessFactors JAM Collaboration
Reproducing the Issue
- Ensure that no SuccessFactors session is open
- Open SF IdP initiated login URL
- The error message is displayed
Cause
IdP-initiated login URL required an active SuccessFactors session to authenticate.
For the SuccessFactors Mobile App, when clicking a third-party link that requires authentication, it is expected that the link will open in a mobile browser rather than within the SuccessFactors Mobile App.
Resolution
In case of using the IdP initiated login URL for accessing any external pages, please make sure to always have a running SuccessFactor session in the same browser, when opening the URL.
Note: This is a proposed workaround due to a limitation in the SuccessFactors Mobile App. If you need to access external pages that require authentication, this can only be done through a mobile browser, not within the SuccessFactors Mobile App.
See Also
Keywords
Error code 10021, company id not present, request@sf_init, SuccessFactors, WorkZone, widget, error message, URL, session, idp, sp, initiated, login, SuccessFactors Mobile App, INC10817736 , KBA , LOD-SF-PLT-SEL , SSO Errors & Logs , LOD-SF-SWZ-WID , Widgets , LOD-SF-PLT-MOB , Mobile Issues , Problem
SAP Knowledge Base Article - Public