Symptom
When saving a Phone Call, with a Subject with more than 255 characters, not all characters are visible in the UI.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Click on Activities work center.
- Select Phone Call.
- Click on + icon
- Select and Account and fulfill the Subject field.
- Add more than 255 characters in the Subject field and Save it.
- Open the Phone Call. The Phone field will not show all characters entered.
Cause
This field's character limit is set to 255 characters as part of the system's original design. This restriction accommodates multiple use cases, including integration with Live Activity and Phone Call functionalities.
Increasing the character limit could have significant impacts on the user interface (UI). For instance, longer subject fields can clutter the UI, making it more difficult to read and display information properly. Additionally, when using a Computer Telephony Integration (CTI) for phone calls, content from the payload is copied to the subject line, and other object information may be appended, further extending its length.
To ensure brevity and clarity, the decision was made to maintain a maximum character limit of 255 for this field.
Resolution
In case you would like to request a change in the existing system logic, you need to post your request in the Influence page; there you can request the new features for the new releases of the system. This channel also allows you to follow up your requests directly with the C4C Product Management Team
https://influence.sap.com/sap/ino/#/campaign/1867
Posting it there is a must, since such requests are not handled via standard Support Channel. Any changes to the existing system might impact the existing customers and user experience in different ways. Our PM team can check the requests, validate any side effects and then consider it via the Influence Page.
Keywords
Cut; Unable to See; Not Visible; Half Text; Activity; Phone; Call; , KBA , LOD-CRM-LA , Live Activity , How To
SAP Knowledge Base Article - Public