Symptom
Notification filed is available only for the workflow defined with time set as "On every Save", However notification option disappears when any defined workflow with time set as "Scheduled" workflow.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Navigate to the Workflow Rules work center view.
- Create a new rule.
- In Step 1, enter a name, select the object as "Opportunity", and set the timing as "On Every Save".
- Go to Step 2 and enter any condition or leave it blank.
- Go to Step 3, the Field dropdown should have the "Notification" option.
- Go back to Step 1 as listed in point 4 above.
- Change the timing to "Scheduled" and enter a schedule, such as 2 seconds after "Created On".
- Go to Step 3.
- Field dropdown value option as "Notification" is missing.
Cause
Notification option is not available for workflows with the timing set as "Scheduled".
Resolution
This is the current and expected behavior of the system.
To create a Notification Workflow Rule, you need to follow these steps:
- Go to the Administrator work center.
- Navigate to the Workflow Rules work center view.
- Create a new rule.
- In Step 1, enter a name, select the object as "Opportunity", and set the timing as "On Every Save".
- Go to Step 2 and enter any condition or leave it blank.
- Go to Step 3, the Field dropdown should have the "Notification" option.
- Under "Send Notification" you can select the options "After", "Before" or "On" and the "Relative Time"
Keywords
Workflow, Rule Type, Notification, Scheduled, Opportunity, Administrator work center, Workflow Rules, Rule creation, Rule editing, Notification bell. , KBA , LOD-CRM-WKF , Workflow , LOD-CRM-OPP , Opportunity Management , LOD-CRM-SRP , Service Request Processing , Problem