SAP Knowledge Base Article - Public

3550426 - Sales Order Replication Fails with Invalid Cancellation Status Error

Symptom

You replicate Sales Orders from S/4 to Service Cloud V2. 
However in message monitoring of Service Cloud we receive the following error: 

sap.crm.salesorderservice.entity.salesOrderS4ReplicationMessageIn

   {
            "code": "400",
            "message": "{\"error\":{\"code\":\"salesOrder.100205\",\"target\":\"cancellationStatus\",\"message\":\"The cancellationStatus  is invalid.\"}}"
        }

Environment

Iflow:

Replicate Sales Orders from SAP S4HANA 

Replicate Sales Order and Sales Quote from SAP S4HANA

SAP Cloud for Sales Version 2

S4/Hana

Reproducing the Issue

  1. Log in S4H
  2. Run the report RCOD_SALES_ORDER_EXTRACT.
  3. Fill out the mandatory fields and Run.
  4. Log in C4C CNS
  5. Go to Settings
  6. Go to Message Monitoring
  7. Search for the erroneous message corresponding to the service entity:sap.crm.salesorderservice.entity.salesOrderS4ReplicationMessageIn 

Error text: The cancellationStatus  is invalid

Cause

If you create an order in S4/Hana without any items and save, the inbound replication will fail with the aforementioned error. 

Resolution

Ensure you are transferring Sales Order to CNS along with Product Item(s). 

For validation purpose; You can also delete the sales orders without item and retry.

Keywords

cancellationStatus;salesOrder.100205;sap.crm.salesorderservice.entity.salesOrderS4ReplicationMessageIn , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Known Error

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0