Symptom
When trying to Upsert a username of an user, you are getting error below:
The error message encountered is "DUPLICATE_USERNAME : Failed to add/update user [Employee4] \"\" (N/A;N/A;N/A): Duplicate Username - \"testidm.employee4@swstest.onmicrosoft.com\". with the index 0".
Environment
SAP SuccessFactors HCM Suite
Cause
The system cannot handle duplicated usernames, and this is an expected behavior of the system.
Resolution
There is no way to avoid such error, since this is expected. But in case you have terminated employees that are using the username that you would like to Upsert, you can try using below workaround:
When an employee is terminated, a logic can be created to include "_terminated" at the end of the username every time the employee gets terminated.
In case of rehire with new employment, the email address can be copied normally without issues and a duplicated username error should not be received.
This is just a suggestion, and you can think in different ones that might also work for you, but the behavior is expected.
See Also
Keywords
User ID, update, MS Entra, rehired, employees, SuccessFactors, Azure, active, inactive, username, duplicate. , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-ODATA , OData API Framework , Problem