Symptom
When filtering for All Logs for a Invoice Run ID, the latest logs are not displayed. Only the first 10000 logs are displayed in the UI.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing Work Center.
- Go to the Invoice Documents View.
- Go to the Invoice Runs View.
- Select the Invoice Run ID ABC (where ABC represents the Invoice Run ID).
- Select Execution Details.
- Filter for All Logs.
The latest logs are not displayed. Only the first 10000 logs are displayed in the UI.
Cause
When filtering for All Logs of a specific the Invoice Run, the system always display the records from the First Logs created to the Latest Logs created.
Currently for any search performed in the system, there is a restriction in which only the first 10000 records are displayed. This occurs in order to preserve the system performance.
To overcome this behavior, it is always recommended to use the Advance Filter option in order personalize the search so the specific records required are displayed.
However, the Advance filter option is currently not available when filtering for all logs of a Invoice Run ID in the Execution Details tab, therefore it is currently not possible to filter for specific old logs after the 10000 log is register for a Invoice Run ID.
Resolution
This is current the standard system behavior.
Keywords
Invoice Run, Execution Details, 10000, All Logs , KBA , SRD-CRM-INV , Customer Invoicing , How To
SAP Knowledge Base Article - Public