SAP Knowledge Base Article - Public

3550571 - SSN not consistently populated in I-9 Form - Onboarding 1.0

Symptom

Social Security Number value is not always populated into I-9 form for all candidates who have Social Security Card selected as List C eligibility document.

(*Key: I9ListCDocTitle = U.S. SOCIAL SECURITY ACCOUNT NUMBER CARD)

Environment

SAP SuccessFactors Onboarding 1.0

Reproducing the Issue

  1. Candidate has List C Document selected as Social Security Card
  2. Some candidates have SSN value populated in I-9 form but some not

Cause

Expected system behavior based on user handling:

# For candidates with SSN blank in I-9, List C document has been selected different from Social Security Card (e.g. US Birth Certificate, etc.) during New Employee Step. Later during Orientation Step, List C document is changed to Social Security Card by manager. 

# As I-9 Section 1 is generated after NES and Social Security Card is not selected during NES, the SSN value is not populated into I-9 Section 1.

  • ※ This happens only in case of non E-Verify location candidates. If E-Verify is necessary, SSN will be populated whatever the List C document is selected.

# As per the existing behavior, if there is any change in SSN data during OS, it'll be considered as data change and then only Section 1 will get re-generated for signing.
However, in this case, the List C document selection is changed but the provided SSN is still matching with the SSN provided in NES, hence Section 1 doesn't get re-generated and SSN is still left blank.

Resolution

It's considered not much impact on current behavior with SSN blank in I-9 Section 1 form because such candidate will not participate in E-Verify.

[Workaround]

Select Social Security Card as List C document in case if it is present during NES.

Keywords

SAP, SuccessFactors, Onboarding 1.0, SSN, ListC, I-9, empty, missing , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , Product Enhancement

Product

SAP SuccessFactors Onboarding all versions