SAP Knowledge Base Article - Public

3550829 - Internal Server Error when accessing HANA Database Explorer in SAP Datasphere

Symptom

  • An attempt to access the HANA Database Explorer results in an Internal Server Error.
  • Not possible to access DB Explorer using a Database Analysis User.
  • The error occurs after denying the new "Application Authorization" prompt that appears.
  • Once the error occurs, the Database Explorer becomes inaccessible across all tenants with any database user.

Environment

SAP Datasphere

Reproducing the Issue

  1. In SAP Datasphere, attempt to access the Database Explorer.
  2. Deny the new "Application Authorization" prompt that appears after logging in from SAP BTP.

Cause

The issue is caused by denying all checkboxes in the new "Application Authorization" prompt that appears after logging in from SAP BTP.
This results in an Internal Server Error, making the Database Explorer inaccessible.

Resolution

Workaround:

  1. Open URL: https://uaa.cf.<tenantRegion>.hana.ondemand.com/profile
    tenantRegion: e.g. eu10, us20, ap11...
  2. You will be prompted with the latest check/authorization info you did last time, then you can check everything/something then validate.
  3. Once done, you should be able to run the Database Explorer again.

Final fix:

Still to be delivered. Once we have concrete information about it, this document will be updated.

Keywords

SAP Datasphere, Database Explorer, Internal Server Error, Application Authorization, Access Denied, SAP BTP, logging. , KBA , DS-SEC , Security (Users, Roles) , Known Error

Product

SAP Datasphere all versions