SAP Knowledge Base Article - Public

3550863 - Internal server error when filtering products in products list

Symptom

Search for products in Product Search Filters leads to an Internal Server error. No error in developer console and no error in logs.

Environment

SAP SALES CLOUD CPQ

Reproducing the Issue

  1. Go to Setup then click on Products
  2. Click the filter icon to get a filter for each column
  3. Filter the products by any part number or system id
  4. We get an error: Server specific error occured

Cause

The functionality for displaying the active product version in the product setup has a performance problem when having lots of product versions and lots of products.

Resolution

The application Parameter Show product version active today of the products synced from the back office in setup needs to be set to False

Keywords

Products search filter, Products list filter, search filters, internal server error , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ 2024