Symptom
Search for products in Product Search Filters leads to an Internal Server error. No error in developer console and no error in logs.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Go to Setup then click on Products
- Click the filter icon to get a filter for each column
- Filter the products by any part number or system id
- We get an error: Server specific error occured
Cause
The functionality for displaying the active product version in the product setup has a performance problem when having lots of product versions and lots of products.
Resolution
The application Parameter Show product version active today of the products synced from the back office in setup needs to be set to False
Keywords
Products search filter, Products list filter, search filters, internal server error , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem
Product
SAP CPQ 2024