Symptom
Customer contract invoice request ABC has the status "Processed" and the line item(s) within are "Not Relevant" status despite not yet being invoiced.
Where ABC is the ID of the preceding contract.
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to work centre: Sales Orders.
- Select view: Contracts.
- Search All Orders: ABC.
- Edit, View All.
- Go to the Items tab.
- Here you can see line item(s) with the item type 'Service - time and material'.
- The line item(s) Fulfillment status read as 'Finished'.
- Go to the Document Flow tab, there is no follow-up invoice document(s).
- Now go to work centre: Customer Invoicing.
- Select the view: Invoice Requests.
- Search All Invoice Requests: ABC.
- Here you find customer contract invoice request ABC "Processed" and the line item(s) within are "Not Relevant" status despite not yet being invoiced.
Cause
The items contained within the contracts do not have invoice requests visible due to their item type; 'Service - time and material' and had their fulfilment finished manually in the contract. This item type should have been invoiced via a service confirmation.
Resolution
- Go to work centre: Sales Orders.
- Select view: Contracts.
- Search All Contracts: ABC.
- Edit, View All.
- Go to the Items tab.
- Select the 'Service - time and material' item to be invoiced.
- With the item selected, Revoke -> Fulfilment.
- Once the item is revoked Submit -> Confirm Execution.
- In the New Service Confirmation window Add Row.
- Select the Product value head, the relevant 'Service - time and material' will be visible in the drop down.
See Also
Refer to Knowledge Base Articles:
Keywords
Invoice, Contracts, Sales Order, Service - time and material, Item Type, Invoice Requests, Processed Status, Not Relevant Status, Fulfilment, Service Confirmation, CRM Scenario, Services and Expenses, Expense - Time and Material. , KBA , SRD-CRM-INV , Customer Invoicing , Problem