SAP Knowledge Base Article - Public

3551162 - Customer Contract Invoice Request "Processed" Despite Contract Line Item(s) Remaining Outstanding

Symptom

Customer contract invoice request ABC has the status "Processed" and the line item(s) within are "Not Relevant" status despite not yet being invoiced.

Where ABC is the ID of the preceding contract.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to work center: Sales Orders.
  2. Select view: Contracts.
  3. Search All Orders: ABC.
  4. Edit, View All.
  5. Go to the Items tab.
  6. Here you can see line item(s) with the item type 'Service - time and material'.
  7. The line item(s) Fulfillment status read as 'Finished'.
  8. Go to the Document Flow tab, there is no follow-up invoice document(s).
  9. Now go to work center: Customer Invoicing.
  10. Select the view: Invoice Requests.
  11. Search All Invoice Requests: ABC.
  12. Here you find customer contract invoice request ABC "Processed" and the line item(s) within are "Not Relevant" status despite not yet being invoiced.

Cause

The items contained within the contracts do not have invoice requests visible due to their item type; 'Service - time and material' and had their fulfilment finished manually in the contract. This item type should have been invoiced via a service confirmation.

Resolution

  1. Go to work center: Sales Orders.
  2. Select view: Contracts.
  3. Search All Contracts: ABC.
  4. Edit, View All.
  5. Go to the Items tab.
  6. Select the 'Service - time and material' item to be invoiced. 
  7. With the item selected, Revoke -> Fulfilment.
  8. Once the item is revoked Submit -> Confirm Execution.
  9. In the New Service Confirmation window Add Row.
  10. Select the Product value head, the relevant 'Service - time and material' will be visible in the drop down.

Please note that if the Contract Item End Date is in the past, the Fulfilment cannot be revoke, the Invoice Status will also automatically be Finished and the Item will be Completed.

See Also

Refer to Knowledge Base Articles:

  • 2875052 - CRM Scenario: Services and Expenses in Sales Order (Summary Table)
  • 2873932 - CRM Scenario: Expense - Time and Material in Sales Order

Keywords

Invoice, Contracts, Sales Order, Service - time and material, Item Type, Invoice Requests, Processed Status, Not Relevant Status, Fulfilment, Service Confirmation, CRM Scenario, Services and Expenses, Expense - Time and Material, Finish; Fullfillment, Finish, Invoicing, Invoice Status, Finished, not invoiced, Revoke, Invoice Request, , KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions