SAP Knowledge Base Article - Public

3551182 - Error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists" is occuring while hiring - 2H 2024

Symptom

When hiring the employee, after clicking continue in after job information, the error “Looks like something went wrong. Please try again or contact Product Support, if the problem persists.” is occurring

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Manage Pending Hire.
  2. Select user to process the hire.
  3. Proceed to the continue button until you try to submit, then system shows error "Looks like something went wrong. Please try again or contact Product Support, if the problem persists" after Job info portlet. 

Cause

It is happening because following two properties were to set the field in PaymentInformation Detail MDF object.

  1. In object definition for "Payment information detail" MDF object, for field "Mask value on UI" property is set to "Yes".
  2. In Legislatively Sensitive Data Configuration for "PaymentInformationV3" object, Read Access Log Configuration for field is set to "Yes".

Resolution

  • Code fix checked in to trunk with ECT-246629 and would be delivered to customer with b2505 release.
  • As a workaround, please set Read Access Log Configuration for field as "No" in Legislatively Sensitive Data Configuration for "PaymentInformationV3" object.

Keywords

KI2411, 2H 2024, INC10258904, Payment information, Manage pending hire, error, Legislatively Sensitive Data Configuration, masked, UI, "Looks like something went wrong. Please try again or contact Product Support, if the problem persists" , KBA , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , Known Error

Product

SAP SuccessFactors Employee Central 2411